
<!DOCTYPE html>
<html lang="en">
<head>

<title>
	G-III Apparel Supplies Earnings Report, Bursts Upward | PriceTargets.com
</title><meta charset="utf-8" /><meta name="viewport" content="width=device-width, height=device-height, initial-scale=1.0" /><meta name="google-site-verification" content="cQ4r8YskHZara3m4DKAOXoTEbO6717RutrSK3OxAX_U" /><meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" /><meta name="theme-color" content="#2f283a" />
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->


<link rel="shortcut icon" href="/images/2favicon.png" /><link rel="apple-touch-icon" href="/images/apple-touch-icon-180x180.png" />

<link href="https://fonts.googleapis.com/css2?family=Inter:wght@300;500;600&amp;display=swap" rel="stylesheet" /><link href="/Style/ARNMasterStyles.css?v=20210529" rel="stylesheet" /><link rel="sitemap" type="application/xml" title="Sitemap" href="https://www.pricetargets.com/Sitemap.ashx" /><link rel="sitemap" href="https://www.pricetargets.com/Sitemap.ashx" />

<!--[if lt IE 9]>
        <link rel="stylesheet" href="/Style/olderbrowsers/css/bootstrap.min.css" media="all" />
        <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
        <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
<link rel="publisher" href="https://plus.google.com/114849885938379193299/" />
<!--[if IE]>
    
    <![endif]-->
<!--[if lt IE 9]>
      <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
    <![endif]-->
<!--[if (gte IE 9) | (!IE)]><!-->
<script defer src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
<!--<![endif]-->
<!-- -->
<link rel="manifest" href="/manifest.json" />
<script src="https://accounts.google.com/gsi/client" async defer></script>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>




       function registerUserChange(action) {
           OneSignal.getUserId(function (userId) {
               OneSignalIdString = userId;
               var Domain = 'analystratings.net';
               var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
               var xhr = new XMLHttpRequest();
               xhr.open('GET', url);
               xhr.onload = function () {
                   if (xhr.status !== 200) {
                       console.log('GET failed.  Returned status of ' + xhr.status);
                   }
                   else {
                       console.log('GET succeeded (' + url + ').  Returned status of ' + xhr.status);
                   }
               };
               xhr.send();
           });
       }

    var OneSignal = OneSignal || [];
       OneSignal.push(
           function () {
               OneSignal.init({
                   appId: "3c4d8727-d855-4e1c-ad92-4049d77fdb9d",
                   safari_web_id: 'web.onesignal.auto.64063cbd-bb2e-4678-8d54-7a11e3cbaa94',
                   autoRegister: false,
                   autoResubscribe: true,
                   notifyButton: {
                       enable: false
                   },
                   welcomeNotification: {
                       "title": "Join Wall Street's Brightest Minds.",
                       "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
                       "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
                   },
               });
               OneSignal.once('subscriptionChange', function (isSubscribed) {
                   if (isSubscribed) {
                       registerUserChange("subscribe");
                   }
                   else {
                       registerUserChange("unsubscribe");
                   }
               });
               if ((navigator.userAgent.toLowerCase().indexOf('firefox') > -1) || ((navigator.userAgent.toLowerCase().indexOf('safari') > -1) && (!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))) {
                   OneSignal.showSlidedownPrompt();
               } else {
                   OneSignal.showNativePrompt();
               }
           });

        

   </script>
<script data-ad-client="ca-pub-9373162611283935" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<meta name="description" content="Clothing maker G-III Apparel (NASDAQ:GIII) recently released its earnings report, a move sufficient to drive the company up 5.8% in premarket trading." /><meta name="keywords" content="g-III apparel stock, earnings, price target, guridance " /></head>
<body>
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="bg-eggplant">
<div class="header-1">
<div class="container">
<div class="row d-lg-flex pt-1">
<div class="c w-25">
<a href="https://www.pricetargets.com/" style="display:inline-block;max-width:calc(100vw - 120px)">
<img width="260" height="50" src="/images/analyst-price-targets-logo.svg?v=2" alt="PriceTargets.com logo" />
</a>
<div style="float:right;" class="header-menu-trigger hamburger hamburger--collapse js-hamburger">
<div class="hamburger-box">
<div class="hamburger-inner"></div>
</div>
</div>
</div>
<nav class="c w-75 header-menu">
<ul>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/brokerages/">Ratings Issuers</a>
<ul>
<li><a href="/brokerages/bank-of-america-stock-recommendations/">Bank of America</a></li>
<li><a href="/brokerages/citigroup-stock-recommendations/">Citibank</a></li>
<li><a href="/brokerages/goldman-sachs-group-stock-recommendations/">Goldman Sachs</a></li>
<li><a href="/brokerages/morgan-stanley-stock-recommendations/">Morgan Stanley</a></li>
<li><a href="/brokerages/wells-fargo-co-stock-recommendations/">Wells Fargo</a></li>
<li><a href="/brokerages/">View All</a></li>
</ul>
</li>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/sectors/">Stocks By Sector</a>
<ul>
<li><a href="/basic-materials-stocks/">Basic Materials</a></li>
<li><a href="/consumer-stocks/">Consumer</a></li>
<li><a href="/energy-stocks/">Energy</a></li>
<li><a href="/finance-stocks/">Finance</a></li>
<li><a href="/healthcare-stocks/">Healthcare</a></li>
<li><a href="/industrials-stocks/">Industrials</a></li>
 <li><a href="/real-estate-stocks/">Real Estate</a></li>
<li><a href="/retail-stocks/">Retail</a></li>
<li><a href="/technology-stocks/">Technology</a></li>
<li><a href="/transportation-stocks/">Transportation</a></li>
</ul>
</li>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/exchanges/">Stocks By Exchange</a>
<ul>
<li><a href="/NYSE/">New York Stock Exchange (NYSE)</a></li>
<li><a href="/NASDAQ/">NASDAQ</a></li>
<li><a href="/OTCMKTS/">Over The Counter (OTCMKTS)</a></li>
<li><a href="/LON/">London Stock Exchange (LSE)</a></li>
<li><a href="/TSE/">Toronto Stock Exchange (TSE)</a></li>
</ul>
</li>
<li><a class="level-1 bg-eggplant" href="/news/">News</a></li>
<li class="has-submenu">
<a class="level-1 bg-eggplant" href="/about/">About</a>
<ul>
<li><a href="/about/">About</a></li>
<li><a href="/authors/">Authors</a></li>
<li><a href="/contact/">Contact</a></li>
</ul>
</li>
<li>
<a class="level-1 bg-eggplant" href="javascript:openModal('companySearch');">Search</a>
</li>
<li>
<a href="#" class="button-header bg-eggplant" onclick="openModal('overlaySquareWhiteBlackMenuButton', 1, 'ARNet-popup');">Sign Up</a>
</li>
</ul>
</nav>
</div>
</div>
</div>
<div id='g_id_onload' data-client_id='178542853386-plp54kefhk8f9nq4770tavoqc0u5268b.apps.googleusercontent.com' data-login_uri='https://www.pricetargets.com/users/OneTapVerifyRedirect.aspx' data-auto_select='false' data-cancel_on_tap_outside='true' data-state_cookie_domain='marketbeat.com' data-skip_prompt_cookie='arnonetap'></div>
<div class="container">
<div id="flexPlace">
</div>
</div>
</div>
</header>
<main id="main">
<form method="post" action="./" id="form1">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="15ADE6CF" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/wEdAAOfJEhxSgCgS/jl767CekMkRNsEg3Wa+DxW2r/ozlHNsnQo658hAh0LotAhxSAvsX+N2pek3Speyd34g1Sq9AuuP456YoF10ZFYlGDuTHGKjA==" />
<div class="container py-1">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5992787070" data-ad-format="auto" data-full-width-responsive="true"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<hr class="mb-2" />
<article>
<h1>G-III Apparel Supplies Earnings Report, Bursts Upward</h1>
<div class="byline-size pb-1">Monday, June 7, 2021 by Steve Anderson</div>
<div class="row d-lg-flex">
<div class="c" style="flex: 5 0 337px; -ms-flex: 5 0 337px;">
<div class="body-copy">
<img class="alignleft" src="https://www.marketbeat.com/logos/articles/small_Depositphotos_4096790_s-2019.jpg" alt="G-III Apparel Supplies Earnings Report, Bursts Upward" width="660" height="495" />
<p>Clothing maker G-III Apparel (<a href="https://www.pricetargets.com/NASDAQ/GIII">NASDAQ:GIII</a>) recently released its earnings report, a move sufficient to drive the company up 5.8% in premarket trading. It's held onto those gains going into this morning's trading session as well, adding further momentum. <a href="https://www.pricetargets.com/news/hanesbrands-delivers-solid-earnings-report-and-plans-for-improvement/">G-III Apparel group</a> subsidiaries, like DKNY and Donna Karan, helped the company offer up not only consensus-beating results for the first quarter of its fiscal 2022 year, but also an upbeat look at the full year. The current word from financial analysts, however, urges caution and has done so for some time now, with ratios of buyers and holders maintaining firm.</p>
<p><strong>G-III Apparel Earnings Report Destroys Expectations</strong></p>
<p>G-III Apparel turned in a magnificent earnings report, bringing in $0.53 per share earnings against a consensus expectation of just $0.15 per share. That also blows away the earnings posted from the first fiscal quarter of 2021, in which the company posted a loss of $0.82 per share.</p>
<p>Revenue, meanwhile, also knocked expectations for a loop. The company saw net sales for the first quarter come in at $519.9 million, which handily beat back the Zacks consensus that called for $460.6 million in revenue. It also represented a significant win over this time last year, in which the company posted a reported $405.1 million in sales.</p>
<p>This year's results were mainly traced to improvements in sportswear as well as wear-to-work lines of apparel, both of which were called on extensively as workers returned to offices at varying degrees. The company's chairman and CEO, <a href="https://www.pricetargets.com/news/expect-gaps-nyse-gps-outperformance-to-continue/">Morris Goldfarb</a>, pointed to G-III Apparel's diversity of wear as well as internal restructuring. The company has reportedly closed the last of its Wilsons Leather and G.H. Bass stores as well.</p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5992787070" data-ad-format="auto" data-full-width-responsive="true"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><hr><br>
<p>The company also issued full-year guidance that looked fairly upbeat. The company doesn't expect any significant return of government-mandated restrictions or even outright store closures like those seen this time last year. The forecast looks for net sales around $2.57 billion, which is a nice upward turn from the $2.06 billion seen last year. This is especially true given that last year's net sales included $91.8 million from Wilsons Leather and G.H. Bass stores. G-III Apparel also looks for net income to come in in the $2.60 to $2.70 per share range, for a total of between $125 million and $135 million.</p>
<p><strong>What Are Financial Analysts Saying About GIII Stock?</strong></p>
<p>Currently, <a href="https://www.pricetargets.com/NASDAQ/GIII/#price-targets">financial analysts</a> are urging caution for those interested in buying in on <a href="https://www.pricetargets.com/news/a-great-fit-at-levi-strauss-nyse-levi-with-beats-and-expectations/">G-III Apparel stock</a>, our latest research notes. However, the proportions of analyst advice, overall, is revealing an unusually stable ratio track. The company currently has a consensus rating of &ldquo;hold&rdquo;, and has held this rating for more than two years now.</p>
<p>A year ago, the company had four &ldquo;buy&rdquo; ratings, six &ldquo;hold&rdquo; ratings, and one &ldquo;sell&rdquo; rating to its credit. Six months ago, that changed slightly to three &ldquo;buy&rdquo;, six &ldquo;hold&rdquo; and one &ldquo;sell&rdquo; rating. Today, however, we stand at two &ldquo;buy&rdquo;, four &ldquo;hold&rdquo; and one &ldquo;sell.&rdquo; While the total number of analysts involved has declined, the two-to-one ratio of &ldquo;hold&rdquo; to &ldquo;buy&rdquo; has held.</p>
<p><a href="https://www.pricetargets.com/news/stich-fix-loses-ground-in-analyst-ratings/">GIII stock price targets</a>, meanwhile, occupy a comparatively narrow range. Currently, the average share price target is $29.29, bookended by a high of $38 and a low of $17.</p>
<p>Recent movement is nonexistent. There hasn't been a change seen in the company's analyst outlook since March, though the movements from March were overwhelmingly positive. March 19 saw four different analysts&mdash;B. Riley, KeyCorp, Barclays and Piper Sandler&mdash;all raise their price targets on the company. KeyCorp and Piper Sandler bumped theirs up substantially&mdash;KeyCorp went from $30 to $38 and Piper Sandler went from $21 to $30&mdash;but B. Riley and Barclays offered more incremental increases. B. Riley went from $33 to $38, and Barclays was up from $24 to $27.</p><h2 class='h3'>Companies in This Article:</h2><table class='tscrollable tsortable' style='line-height:1.2em'><thead><tr><th data-sort='string'>Company</th><th data-sort='float'>Current Price</th><th data-sort='float'>Price Change</th><th data-sort='float'>Dividend Yield</th><th data-sort='float'>P/E Ratio</th><th data-sort='float'>Consensus Rating</th><th data-sort='float'>Consensus Price Target</th></tr></thead><tbody><tr><td>G-III Apparel Group (<a href='/NASDAQ/GIII/'>GIII</a>)</td><td data-sort-value='34.8'>$34.80</td><td class='c-green' data-sort-value='0.106870229007633'>+10.7%</td><td data-sort-value='0'>N/A</td><td data-sort-value='75.65'>75.65</td><td data-sort-value='2.14285714285714'>Hold</td><td data-sort-value='27.5'>$27.50</td></tr></tbody></table>
</div>
<div>
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatArticlePage.aspx" title="More on MarketBeat"></iframe>
</div>
</div>
<div class="c" style="flex: 0 0 337px; -ms-flex: 0 0 337px;">
<div class="mb-2 bg-eggplant p-1">
<h2 class="h2 m-0">Get New Analyst Ratings Delivered To Your Inbox</h2>
<div class="py-1">Enter your email address below to receive a concise daily summary of analysts' upgrades, downgrades and new coverage with <a href="https://www.marketbeat.com/?utm_source=PriceTargetCom&utm_campaign=PriceTargetCom&utm_medium=PriceTargetCom" class="no-a">MarketBeat</a>'s FREE daily email newsletter.</div>
<div class="pb-1">
<input name="ctl00$cphPrimaryContent$InPostRegistrationEmail" type="text" id="cphPrimaryContent_InPostRegistrationEmail" name="RegisterEmail" placeholder="your@email.here" aria-label="Enter Your Email" class="transparent-input" style="width:100%;" />
</div>
<div class="pb-1">
<input type="submit" name="ctl00$cphPrimaryContent$btnSubmit" value="Sign Up Now (Free)" onclick="return CheckEmail(&#39;cphPrimaryContent_InPostRegistrationEmail&#39;, &#39;ShowSuggestionInPost&#39;);" id="cphPrimaryContent_btnSubmit" class="button button-gold" style="width:100%;" />
</div>
</div>
<div>
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx?PlaceOnArticlePage=1" width="336" height="600" frameborder="no" title="More Articles"></iframe>
</div>
<h2 class='m-0 h3'>Most Read This Month</h2><ul class='styled-list m-0'><li><a href='/news/amc-entertainment-shares-spike-heres-why/'>AMC Entertainment Shares Spike - Here's Why</a></li><li><a href='/news/new-recommendation-fuels-nikola-share-price-surge/'>New Recommendation Fuels Nikola Share Price Surge</a></li><li><a href='/news/bank-of-america-securities-wont-touch-two-meme-stocks/'>Bank of America Securities Won't Touch Two Meme Stocks</a></li><li><a href='/news/amc-entertainment-surges-on-big-stock-buy/'>AMC Entertainment Surges on Big Stock Buy</a></li><li><a href='/news/dillards-surges-227-after-spectacular-earnings-report/'>Dillard's Surges 22.7% After Spectacular Earnings Report</a></li></ul><h2 class='h3 mt-2'>Recent Articles</h2><ul class='styled-list m-0'><li><a href='/news/g-iii-apparel-supplies-earnings-report-bursts-upward/'>G-III Apparel Supplies Earnings Report, Bursts Upward</a></li><li><a href='/news/bank-of-america-securities-wont-touch-two-meme-stocks/'>Bank of America Securities Won't Touch Two Meme Stocks</a></li><li><a href='/news/five-below-turns-in-earnings-report-surges-ahead/'>Five Below Turns in Earnings Report, Surges Ahead</a></li><li><a href='/news/tilray-spikes-with-new-analyst-sentiment/'>Tilray Spikes With New Analyst Sentiment</a></li><li><a href='/news/petmed-express-surges-as-trading-volume-soars/'>PetMed Express Surges As Trading Volume Soars</a></li></ul>
</div>
</div>
</article>
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/ViewCount.ashx?type=j&id=4750606&referrer=' + encodeURIComponent(document.referrer) + '" alt="" />');</script>
</div>
<div class="container">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5992787070" data-ad-format="auto" data-full-width-responsive="true"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
<script type="application/ld+json"> { "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage": { "@type": "WebPage", "@id": "https://www.pricetargets.com/news/g-iii-apparel-supplies-earnings-report-bursts-upward/" }, "headline": "G-III Apparel Supplies Earnings Report, Bursts Upward", "image": { "@type": "ImageObject", "url": "https://www.marketbeat.com/logos/articles/small_Depositphotos_4096790_s-2019.jpg", "height": "400", "width": "400" }, "datePublished": "2021-06-07", "dateModified": "2021-06-07", "author": { "@type": "Person", "name": "Steve Anderson", "url":"https://www.pricetargets.com/authors/steve-anderson/" }, "publisher": { "@type": "Organization", "name": "PriceTargets.com", "logo": { "@type": "ImageObject", "url": "https://www.pricetargets.com/images/arn-h-logo-2c-light-bkg-rgb-300px@72ppi.jpg", "width": "300", "height": "53" } }, "description": "Clothing maker G-III Apparel (NASDAQ:GIII) recently released its earnings report, a move sufficient to drive the company up 5.8% in premarket trading." } </script><link rel="canonical" href="https://www.pricetargets.com/news/g-iii-apparel-supplies-earnings-report-bursts-upward/" /><link rel="amphtml" href="https://www.pricetargets.com/news/g-iii-apparel-supplies-earnings-report-bursts-upward/amp/" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="@MarketBeatCom" /><meta name="twitter:title" content="G-III Apparel Supplies Earnings Report, Bursts Upward" /><meta name="twitter:description" content="Clothing maker G-III Apparel (NASDAQ:GIII) recently released its earnings report, a move sufficient to drive the company up 5.8% in premarket trading." /><meta name="twitter:creator" content="@MarketBeatCom" /><meta name="twitter:image" content="https://www.marketbeat.com/logos/articles/small_Depositphotos_4096790_s-2019.jpg" /><meta property="og:title" content="G-III Apparel Supplies Earnings Report, Bursts Upward" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.pricetargets.com/news/g-iii-apparel-supplies-earnings-report-bursts-upward/" /><meta property="og:image" content="https://www.marketbeat.com/logos/articles/small_Depositphotos_4096790_s-2019.jpg" /><meta property="og:description" content="Clothing maker G-III Apparel (NASDAQ:GIII) recently released its earnings report, a move sufficient to drive the company up 5.8% in premarket trading." /><meta property="og:site_name" content="PriceTargets.com" /><meta property="og:locale" content="en_US" />
</form>
</main>
<footer class="bg-eggplant pt-1" style="padding-bottom: 4rem;">
<div class="container py-1">
<p>© American Consumer News, LLC dba PriceTargets.com ® 2010-2021. All rights reserved. 326 E 8th St #105, Sioux Falls, SD 57103. PriceTargets.com provides comprehensive coverage of stock ratings, including equities research analysts’ upgrades, downgrades, new coverage and price target
changes. PriceTargets.com keeps track of all major brokerages’ stock ratings and recommendations, including Goldman Sachs, JPMorgan Chase, Wells Fargo, Bank of America/Merrill Lynch, Citigroup, Morgan Stanley and many more. PriceTargets.com does not provide financial advice and does not issue recommendations or offers to buy stock or
sell any security.</p>
<a href="/accessibility/" style="color:#fff;font-weight:300;">Our Accessibility Statement</a> | <a href="https://www.marketbeat.com/do-not-sell-my-information/" style="color:#fff;font-weight:300;">Do Not Sell My Information</a>
<br />
<br />
<hr class="my-1" />
<p>
© 2021 Market data provided is at least 10-minutes delayed and hosted by <a class="c-white" style="font-weight:300;" href='https://www.barchartmarketdata.com/' rel="noopener nofollow">Barchart Solutions</a>. Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use please see <a class="c-white" style="font-weight:300;" href="https://www.barchartmarketdata.com/terms" rel="noopener nofollow">disclaimer</a>. Fundamental company data provided by Zacks Investment Research. As a bonus to opt-ing into our email newsletters, you will also get a free subscription to the Liberty Through Wealth e-newsletter. You can opt out at any time.
</p>
</div>
</footer>
<script type="text/javascript" src="/scripts/ARNMasterScripts.js?v=20210530b"></script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-0EPCLQ469L"></script>
<script>
        window.dataLayer = window.dataLayer || [];
        function gtag() { dataLayer.push(arguments); }
        gtag('js', new Date());

        gtag('config', 'G-0EPCLQ469L');
    </script>
<script type="text/javascript">loadEntranceModal('ARNet-Popup'); </script>

<script type="text/javascript">
    var sc_project = 12386963;
    var sc_invisible = 1;
    var sc_security = "d815ef40";
    var sc_https = 1; 
    </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/12386963/0/d815ef40/1/" alt="Web Analytics Made Easy - StatCounter"></noscript>

</body>
</html>
