
<!DOCTYPE html>
<html lang="en">
<head>

<title>
	It Might Be Time To Shed Home Depot | PriceTargets.com
</title><meta charset="utf-8" /><meta name="viewport" content="width=device-width, height=device-height, initial-scale=1.0" /><meta name="google-site-verification" content="cQ4r8YskHZara3m4DKAOXoTEbO6717RutrSK3OxAX_U" /><meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" /><meta name="theme-color" content="#2f283a" />
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->


<link rel="shortcut icon" href="/images/2favicon.png" /><link rel="apple-touch-icon" href="/images/apple-touch-icon-180x180.png" />

<link href="https://fonts.googleapis.com/css2?family=Inter:wght@300;500;600&amp;display=swap" rel="stylesheet" /><link href="/Style/ARNMasterStyles.css?v=20210716" rel="stylesheet" /><link rel="sitemap" type="application/xml" title="Sitemap" href="https://www.pricetargets.com/Sitemap.ashx" /><link rel="sitemap" href="https://www.pricetargets.com/Sitemap.ashx" />

<!--[if lt IE 9]>
        <link rel="stylesheet" href="/Style/olderbrowsers/css/bootstrap.min.css" media="all" />
        <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
        <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
<link rel="publisher" href="https://plus.google.com/114849885938379193299/" />
<!--[if IE]>
    
    <![endif]-->
<!--[if lt IE 9]>
      <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
    <![endif]-->
<!--[if (gte IE 9) | (!IE)]><!-->
<script defer src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
<!--<![endif]-->
<!-- -->
<link rel="manifest" href="/manifest.json" />
<script src="https://accounts.google.com/gsi/client" async defer></script>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>




       function registerUserChange(action) {
           OneSignal.getUserId(function (userId) {
               OneSignalIdString = userId;
               var Domain = 'analystratings.net';
               var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
               var xhr = new XMLHttpRequest();
               xhr.open('GET', url);
               xhr.onload = function () {
                   if (xhr.status !== 200) {
                       console.log('GET failed.  Returned status of ' + xhr.status);
                   }
                   else {
                       console.log('GET succeeded (' + url + ').  Returned status of ' + xhr.status);
                   }
               };
               xhr.send();
           });
       }

    var OneSignal = OneSignal || [];
       OneSignal.push(
           function () {
               OneSignal.init({
                   appId: "3c4d8727-d855-4e1c-ad92-4049d77fdb9d",
                   safari_web_id: 'web.onesignal.auto.64063cbd-bb2e-4678-8d54-7a11e3cbaa94',
                   autoRegister: false,
                   autoResubscribe: true,
                   notifyButton: {
                       enable: false
                   },
                   welcomeNotification: {
                       "title": "Join Wall Street's Brightest Minds.",
                       "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
                       "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
                   },
               });
               OneSignal.once('subscriptionChange', function (isSubscribed) {
                   if (isSubscribed) {
                       registerUserChange("subscribe");
                   }
                   else {
                       registerUserChange("unsubscribe");
                   }
               });
               if ((navigator.userAgent.toLowerCase().indexOf('firefox') > -1) || ((navigator.userAgent.toLowerCase().indexOf('safari') > -1) && (!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))) {
                   OneSignal.showSlidedownPrompt();
               } else {
                   OneSignal.showNativePrompt();
               }
           });

        

   </script>
<script data-ad-client="ca-pub-9373162611283935" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<meta name="description" content="The analysts were getting a little bit bullish on Home Depot (NYSE: HD) going into the second-quarter report but those hopes were dashed. Analysts at Morgan Stanley, Evercore ISI, and Raymond James all came out with positive commentary" /><meta name="keywords" content="home depot stock, earnings, price target, guidance " /></head>
<body>
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="bg-eggplant">
<div class="header-1">
<div class="container">
<div class="row d-lg-flex pt-1">
<div class="c w-25">
<a href="https://www.pricetargets.com/" style="display:inline-block;max-width:calc(100vw - 120px)" id="header-logo-link">
<img width="260" height="50" src="/images/analyst-price-targets-logo.svg?v=2" alt="PriceTargets.com logo" />
</a>
<div style="float:right;" class="header-menu-trigger hamburger hamburger--collapse js-hamburger">
<div class="hamburger-box">
<div class="hamburger-inner"></div>
</div>
</div>
</div>
<nav class="c w-75 header-menu">
<ul>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/brokerages/">Ratings Issuers</a>
<ul>
<li><a href="/brokerages/bank-of-america-stock-recommendations/">Bank of America</a></li>
<li><a href="/brokerages/citigroup-stock-recommendations/">Citibank</a></li>
<li><a href="/brokerages/goldman-sachs-group-stock-recommendations/">Goldman Sachs</a></li>
<li><a href="/brokerages/morgan-stanley-stock-recommendations/">Morgan Stanley</a></li>
<li><a href="/brokerages/wells-fargo-co-stock-recommendations/">Wells Fargo</a></li>
<li><a href="/brokerages/">View All</a></li>
</ul>
</li>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/sectors/">Stocks By Sector</a>
<ul>
<li><a href="/basic-materials-stocks/">Basic Materials</a></li>
<li><a href="/consumer-stocks/">Consumer</a></li>
<li><a href="/energy-stocks/">Energy</a></li>
<li><a href="/finance-stocks/">Finance</a></li>
<li><a href="/healthcare-stocks/">Healthcare</a></li>
 <li><a href="/industrials-stocks/">Industrials</a></li>
<li><a href="/real-estate-stocks/">Real Estate</a></li>
<li><a href="/retail-stocks/">Retail</a></li>
<li><a href="/technology-stocks/">Technology</a></li>
<li><a href="/transportation-stocks/">Transportation</a></li>
</ul>
</li>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/exchanges/">Stocks By Exchange</a>
<ul>
<li><a href="/NYSE/">New York Stock Exchange (NYSE)</a></li>
<li><a href="/NASDAQ/">NASDAQ</a></li>
<li><a href="/OTCMKTS/">Over The Counter (OTCMKTS)</a></li>
<li><a href="/LON/">London Stock Exchange (LSE)</a></li>
<li><a href="/TSE/">Toronto Stock Exchange (TSE)</a></li>
</ul>
</li>
<li><a class="level-1 bg-eggplant" href="/news/">News</a></li>
<li class="has-submenu">
<a class="level-1 bg-eggplant" href="/about/">About</a>
<ul>
<li><a href="/about/">About</a></li>
<li><a href="/authors/">Authors</a></li>
<li><a href="/contact/">Contact</a></li>
</ul>
</li>
<li>
<a class="level-1 bg-eggplant" href="javascript:openModal('companySearch');">Search</a>
</li>
<li>
<a href="#" class="button-header bg-eggplant" onclick="openModal('overlaySquareWhiteBlackMenuButton', 1, 'ARNet-popup');">Sign Up</a>
</li>
</ul>
</nav>
</div>
</div>
</div>
<div id='g_id_onload' data-client_id='178542853386-plp54kefhk8f9nq4770tavoqc0u5268b.apps.googleusercontent.com' data-login_uri='https://www.pricetargets.com/users/OneTapVerifyRedirect.aspx' data-auto_select='false' data-cancel_on_tap_outside='true' data-state_cookie_domain='marketbeat.com' data-skip_prompt_cookie='arnonetap'></div>
<div class="container">
<div id="flexPlace">
</div>
</div>
</div>
</header>
<main id="main">
<form method="post" action="./" id="form1">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
</div>
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="15ADE6CF" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/wEdAAPtPLCP0BxbbU1TI9vMPTV/RNsEg3Wa+DxW2r/ozlHNsnQo658hAh0LotAhxSAvsX9ADHVX0F0k5dPnHa0jS/kt0U1cTCPR8rGM20zLo6wtlw==" />
</div>
<div class="container py-1">
<script type='text/javascript'>document.write('<a class="no-a" style="text-decoration:none" target="_blank" rel="noopener nofollow" href="https://www.ame' + 'ricanconsumernews.net/scripts/click.aspx?NativeDisplayAdID=5216&ImpressionID=0&UserID=0&Placement=PlaceOnARNWebsite">');</script><div class="row d-sm-flex" style="font-weight:300;line-height:1.3;"><div class="c" style="float:left;"><div class="my-1 lazy" style="border: solid 1px #fff;width:153px;padding: 0 0 90% 0;background:url('https://www.marketbeat.com/images/webpush/files/thumb_2047push_BRC_02.png');background-size:cover;background-position: center;max-width:23vw;"></div></div><div class="c" style="flex:1;-ms-flex:1;"><div class="border-t py-1 my-1"><div class="h2">An Urgent Message For Any Investor Who's Worried About Inflation</div><div class="byline-size o-80" style="margin-bottom: 10px;"><span>From The Gold Letter</span></div><div style="clear:both;">As Washington Prepares to hit America with record-setting spending. Worried investors are looking for a way to protect their wealth. Many are looking to invest in gold bars, bullion, and coins. However, this "Backdoor Gold Play" is pumping out twice the returns of gold...</div></div></div></div><script type='text/javascript'>document.write('</a>');</script>
<hr class="mb-2" />
<article>
<h1>It Might Be Time To Shed Home Depot</h1>
<div class="byline-size pb-1">Tuesday, August 17, 2021 by Thomas Hughes</div>
<div class="row d-lg-flex">
<div class="c" style="flex: 5 0 337px; -ms-flex: 5 0 337px;">
<div class="body-copy">
<img class="alignleft" src="https://www.marketbeat.com/logos/articles/small_Depositphotos_82411686_s-2019.jpg" alt="It Might Be Time To Shed Home Depot" width="660" height="440" />
<h2>The analysts Were Getting Bullish On Home Depot&hellip;</h2>
<p>The analysts were getting a little bit bullish on <strong>Home Depot </strong><a href="https://www.pricetargets.com/NYSE/HD/"><strong>(NYSE: HD)</strong></a> going into the second-quarter report but those hopes were dashed. Analysts at Morgan Stanley, Evercore ISI, and Raymond James all came out with<a href="https://www.pricetargets.com/NYSE/HD/#upgrades-and-downgrades"> positive commentary </a>just a day before the release and, ironically, one of them at least even made note of Home Depot's biggest problem. Home Depot is one of the biggest winners of the pandemic, it was spurred by stay-at-home trends and stimulus money which is quickly dissipating. Home Depot is still <a href="https://www.pricetargets.com/news/profitability-equation-hits-lowes-nyse-low-but-its-still-a-good-buy/">a great company</a>, it still has great cash flow, and the dividend is sound but it may be time to trim your Holdings in favor of something with a better growth outlook. This stock Is facing a "massive 2-year comparable sales deceleration" and that could cap gains for the foreseeable future.</p>
<h2>Home Depot's Tailwinds Are Weakening</h2>
<p>Home Depot had a good report but there is one factor within it that has shares moving lower. While Revenue growth is positive and exceeded expectations internal metrics reveal revenue acceleration is slowing, weaker than expected, and the comps are only going to get tougher. The company reported $41.12 in net revenue for a gain of 8.1% over last year which is good. That beat the consensus by 380 million dollars or about 90 basis points which is also good but not enough to get excited about. The really damaging figures are the comp store numbers, however, which show the company's quarterly growth is more to do with stores added over the past year than strengths of sales.</p><script type='text/javascript'>document.write('<a class="no-a" style="text-decoration:none" target="_blank" rel="noopener nofollow" href="https://www.ame' + 'ricanconsumernews.net/scripts/click.aspx?NativeDisplayAdID=5269&ImpressionID=0&UserID=0&Placement=PlaceOnARNWebsite">');</script><div class="row d-sm-flex" style="font-weight:300;line-height:1.3;"><div class="c" style="float:left;"><div class="my-1 lazy" style="border: solid 1px #fff;width:153px;padding: 0 0 90% 0;background:url('https://www.marketbeat.com/images/webpush/files/thumb_2051push_HP_03.jpg');background-size:cover;background-position: center;max-width:23vw;"></div></div><div class="c" style="flex:1;-ms-flex:1;"><div class="border-t py-1 my-1"><div class="h2">#1 Streaming Stock to Watch</div><div class="byline-size o-80" style="margin-bottom: 10px;"><span>From Stock Street News</span></div><div style="clear:both;">Discover 7 Reasons Why This Live Streaming Stock Could Be The Biggest Trade of 2021</div></div></div></div><script type='text/javascript'>document.write('</a>');</script><hr><br>
<p>On a comp-store basis, the company reports sales are up 4.5% over last year versus the expectation for 5.6%. Worse, comps in the US came in at 3.4% versus the expectation for nearly 5% growth. Comp sales were impacted by a 5.8% decline in store traffic offset by an 11.3% increase in ticket average which itself isn't that impressive. Inflation has the price of everything moving higher so it's not like Home Depot customers are buying much more product, they're just spending more money. The company did not add any new stores this quarter.</p>
<p>Moving down to the earnings, the news is a little better. The company reported mixed margin improvement but GAAP earnings that came in ahead of the consensus. The $4.53 in GAAP earnings beat the consensus by $0.11 due to a 20 basis point improvement in operating margin and revenue strength. The key takeaway for us is that margin and earnings could have been stronger. The company increased its inventory by 40.1% which cut into the bottom line. That is worth nearly $5.40 billion or more than 100% of the company's GAAP earnings.</p>
<h2>Home Depot Pays A Good Dividend, It's Going To Get Better</h2>
<p>Home Depot pays an attractive dividend and one that we view as safe and with a high expectation for <a href="https://www.pricetargets.com/news/jack-in-the-box-is-reloading-for-another-bounce-higher/">distribution growth</a>. At the current share price the stock is yielding about 2%, the company is paying out only 40% of earnings, there's a history of past increases, and the most recent increases have been double digits. Based on the metrics, we're expecting to see Home Depot increase its dividend by double-digits again this year but there is something else to consider. If share prices continue their downward plunge the distribution will not only grow but the yield on new investment dollars may become significantly better.</p>
<h2>The Technical Outlook: Home Depot Could Fall Another 5% Or More</h2>
<p>Shares of Home Depot are down nearly 5% in early market action and could head even lower. Early support appears to be near the $320 level but if this level is broken, we see this stock moving down to the $300 level. The $300 level is the last level of firm support tested by the market and one that we view as potentially very strong. If price action is not able to regroup at this level, down more than 10% from the high, Home Depot could be in for a much bigger decline.&nbsp;<br /><br /><img class="aligncenter" src="https://www.marketbeat.com/logos/articles/small_chart-HD-8172021_ver001.png" alt="It Might Be Time To Shed Home Depot" width="1200" height="638" /></p><h2 class='h3'>Companies in This Article:</h2><table class='tscrollable tsortable' style='line-height:1.2em'><thead><tr><th data-sort='string'>Company</th><th data-sort='float'>Current Price</th><th data-sort='float'>Price Change</th><th data-sort='float'>Dividend Yield</th><th data-sort='float'>P/E Ratio</th><th data-sort='float'>Consensus Rating</th><th data-sort='float'>Consensus Price Target</th></tr></thead><tbody><tr><td>The Home Depot (<a href='/NYSE/HD/'>HD</a>)</td><td data-sort-value='320.75'>$320.75</td><td class='c-red' data-sort-value='-0.0426801969855246'>-4.3%</td><td data-sort-value='0.020576773187841'>2.06%</td><td data-sort-value='23.40'>23.40</td><td data-sort-value='2.8'>Buy</td><td data-sort-value='332.95652173913'>$332.96</td></tr></tbody></table>
</div>
<div>
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatArticlePage.aspx" title="More on MarketBeat"></iframe>
</div>
</div>
<div class="c" style="flex: 0 0 337px; -ms-flex: 0 0 337px;">
<div class="mb-2 bg-eggplant p-1">
<h2 class="h2 m-0">Get New Analyst Ratings Delivered To Your Inbox</h2>
<div class="py-1">Enter your email address below to receive a concise daily summary of analysts' upgrades, downgrades and new coverage with <a href="https://www.marketbeat.com/?utm_source=PriceTargetCom&utm_campaign=PriceTargetCom&utm_medium=PriceTargetCom" class="no-a">MarketBeat</a>'s FREE daily email newsletter.</div>
<div class="pb-1">
<input name="ctl00$cphPrimaryContent$InPostRegistrationEmail" type="text" id="cphPrimaryContent_InPostRegistrationEmail" name="RegisterEmail" placeholder="your@email.here" aria-label="Enter Your Email" class="transparent-input" style="width:100%;" />
<div id="ShowSuggestionInPost" class="c-white"></div>
</div>
<div class="pb-1">
<input type="submit" name="ctl00$cphPrimaryContent$btnSubmit" value="Sign Up Now (Free)" onclick="return CheckEmail(&#39;cphPrimaryContent_InPostRegistrationEmail&#39;, &#39;ShowSuggestionInPost&#39;);" id="cphPrimaryContent_btnSubmit" class="button button-gold" style="width:100%;" />
</div>
</div>
<div>
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx?PlaceOnArticlePage=1" width="336" height="600" frameborder="no" title="More Articles"></iframe>
</div>

<h2 class='m-0 h3'>Most Read This Month</h2><ul class='styled-list m-0'><li><a href='/news/4-companies-raising-guidance-that-you-should-buy/'>4 Companies Raising Guidance That You Should Buy</a></li><li><a href='/news/the-bottom-is-in-for-greenpower-motor-company/'>The Bottom Is In For GreenPower Motor Company</a></li><li><a href='/news/wendys-is-a-high-quality-burger-stock-for-income-investors/'>Wendy's Is A High-Quality Burger Stock For Income Investors</a></li><li><a href='/news/cronos-group-proves-its-no-flash-in-the-pan/'>Cronos Group Proves It’s No Flash In The Pan</a></li><li><a href='/news/speculators-might-consider-exela-technologies-stock/'>Speculators Might Consider Exela Technologies Stock</a></li></ul><h2 class='h3 mt-2'>Recent Articles</h2><ul class='styled-list m-0'><li><a href='/news/it-might-be-time-to-shed-home-depot/'>It Might Be Time To Shed Home Depot</a></li><li><a href='/news/paysafe-beats-consensus-but-the-market-doesnt-care/'>Paysafe Beats Consensus But The Market Doesn't Care</a></li><li><a href='/news/the-bottom-is-in-for-greenpower-motor-company/'>The Bottom Is In For GreenPower Motor Company</a></li><li><a href='/news/dillards-wins-the-mall-wars/'>Dillard's Wins The Mall Wars</a></li><li><a href='/news/wendys-is-a-high-quality-burger-stock-for-income-investors/'>Wendy's Is A High-Quality Burger Stock For Income Investors</a></li></ul>
</div>
</div>
</article>
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/ViewCount.ashx?type=j&id=4838789&referrer=' + encodeURIComponent(document.referrer) + '" alt="" />');</script>
</div>
<div class="container">
<script type='text/javascript'>document.write('<a class="no-a" style="text-decoration:none" target="_blank" rel="noopener nofollow" href="https://www.ame' + 'ricanconsumernews.net/scripts/click.aspx?NativeDisplayAdID=5269&ImpressionID=0&UserID=0&Placement=PlaceOnARNWebsite">');</script><div class="row d-sm-flex" style="font-weight:300;line-height:1.3;"><div class="c" style="float:left;"><div class="my-1 lazy" style="border: solid 1px #fff;width:153px;padding: 0 0 90% 0;background:url('https://www.marketbeat.com/images/webpush/files/thumb_2051push_HP_03.jpg');background-size:cover;background-position: center;max-width:23vw;"></div></div><div class="c" style="flex:1;-ms-flex:1;"><div class="border-t py-1 my-1"><div class="h2">#1 Streaming Stock to Watch</div><div class="byline-size o-80" style="margin-bottom: 10px;"><span>From Stock Street News</span></div><div style="clear:both;">Discover 7 Reasons Why This Live Streaming Stock Could Be The Biggest Trade of 2021</div></div></div></div><script type='text/javascript'>document.write('</a>');</script><script type='text/javascript'>document.write('<img height="1" width="1" src="https://www.market' + 'beat.com/scripts/NativeDisplayPixel.ashx?NativeDisplayAdID=5269&Placement=PlaceOnARNWebsite" alt="" />');</script>
</div>
<script type="application/ld+json"> { "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage": { "@type": "WebPage", "@id": "https://www.pricetargets.com/news/it-might-be-time-to-shed-home-depot/" }, "headline": "It Might Be Time To Shed Home Depot", "image": { "@type": "ImageObject", "url": "https://www.marketbeat.com/logos/articles/small_Depositphotos_82411686_s-2019.jpg", "height": "400", "width": "400" }, "datePublished": "2021-08-17", "dateModified": "2021-08-17", "author": { "@type": "Person", "name": "Thomas Hughes", "url":"https://www.pricetargets.com/authors/thomas-hughes/" }, "publisher": { "@type": "Organization", "name": "PriceTargets.com", "logo": { "@type": "ImageObject", "url": "https://www.pricetargets.com/images/arn-h-logo-2c-light-bkg-rgb-300px@72ppi.jpg", "width": "300", "height": "53" } }, "description": "The analysts were getting a little bit bullish on Home Depot (NYSE: HD) going into the second-quarter report but those hopes were dashed. Analysts at Morgan Stanley, Evercore ISI, and Raymond James all came out with positive commentary" } </script><link rel="canonical" href="https://www.pricetargets.com/news/it-might-be-time-to-shed-home-depot/" /><link rel="amphtml" href="https://www.pricetargets.com/news/it-might-be-time-to-shed-home-depot/amp/" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="@MarketBeatCom" /><meta name="twitter:title" content="It Might Be Time To Shed Home Depot" /><meta name="twitter:description" content="The analysts were getting a little bit bullish on Home Depot (NYSE: HD) going into the second-quarter report but those hopes were dashed. Analysts at Morgan Stanley, Evercore ISI, and Raymond James all came out with positive commentary" /><meta name="twitter:creator" content="@MarketBeatCom" /><meta name="twitter:image" content="https://www.marketbeat.com/logos/articles/small_Depositphotos_82411686_s-2019.jpg" /><meta property="og:title" content="It Might Be Time To Shed Home Depot" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.pricetargets.com/news/it-might-be-time-to-shed-home-depot/" /><meta property="og:image" content="https://www.marketbeat.com/logos/articles/small_Depositphotos_82411686_s-2019.jpg" /><meta property="og:description" content="The analysts were getting a little bit bullish on Home Depot (NYSE: HD) going into the second-quarter report but those hopes were dashed. Analysts at Morgan Stanley, Evercore ISI, and Raymond James all came out with positive commentary" /><meta property="og:site_name" content="PriceTargets.com" /><meta property="og:locale" content="en_US" />
</form>
</main>
<footer class="bg-eggplant pt-1" style="padding-bottom: 4rem;">
<div class="container py-1">
<p>© American Consumer News, LLC dba PriceTargets.com ® 2010-2021. All rights reserved. 326 E 8th St #105, Sioux Falls, SD 57103. PriceTargets.com provides comprehensive coverage of stock ratings, including equities research analysts’ upgrades, downgrades, new coverage and price target
changes. PriceTargets.com keeps track of all major brokerages’ stock ratings and recommendations, including Goldman Sachs, JPMorgan Chase, Wells Fargo, Bank of America/Merrill Lynch, Citigroup, Morgan Stanley and many more. PriceTargets.com does not provide financial advice and does not issue recommendations or offers to buy stock or
sell any security.</p>
<a href="/accessibility/" style="color:#fff;font-weight:300;">Our Accessibility Statement</a> | <a href="https://www.marketbeat.com/do-not-sell-my-information/" style="color:#fff;font-weight:300;">Do Not Sell My Information</a>
<br />
<br />
<hr class="my-1" />
<p>
© 2021 Market data provided is at least 10-minutes delayed and hosted by <a class="c-white" style="font-weight:300;" href='https://www.barchartmarketdata.com/' rel="noopener nofollow">Barchart Solutions</a>. Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use please see <a class="c-white" style="font-weight:300;" href="https://www.barchartmarketdata.com/terms" rel="noopener nofollow">disclaimer</a>. Fundamental company data provided by Zacks Investment Research. As a bonus to opt-ing into our email newsletters, you will also get a free subscription to the Liberty Through Wealth e-newsletter. You can opt out at any time.
</p>
</div>
</footer>
<script type="text/javascript" src="/scripts/ARNMasterScripts.js?v=20210816"></script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-0EPCLQ469L"></script>
<script>
        window.dataLayer = window.dataLayer || [];
        function gtag() { dataLayer.push(arguments); }
        gtag('js', new Date());

        gtag('config', 'G-0EPCLQ469L');
    </script>
<script>loadEntranceModal('ARN-Popup','NYSE:HD','The Home Depot','https://www.pricetargets.com/logos/home-depot-logo.gif'); </script>

<script type="text/javascript">
    var sc_project = 12386963;
    var sc_invisible = 1;
    var sc_security = "d815ef40";
    var sc_https = 1; 
    </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/12386963/0/d815ef40/1/" alt="Web Analytics Made Easy - StatCounter"></noscript>

</body>
</html>
