
<!DOCTYPE html>
<html lang="en">
<head>

<title>
	KLA Corporation Is On Watch For A Major Breakout | PriceTargets.com
</title><meta charset="utf-8" /><meta name="viewport" content="width=device-width, height=device-height, initial-scale=1.0" /><meta name="google-site-verification" content="cQ4r8YskHZara3m4DKAOXoTEbO6717RutrSK3OxAX_U" /><meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" /><meta name="theme-color" content="#2f283a" />
<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->


<link rel="shortcut icon" href="/images/2favicon.png" /><link rel="apple-touch-icon" href="/images/apple-touch-icon-180x180.png" />

<link href="https://fonts.googleapis.com/css2?family=Inter:wght@300;500;600&amp;display=swap" rel="stylesheet" /><link href="/Style/ARNMasterStyles.css?v=20210716" rel="stylesheet" /><link rel="sitemap" type="application/xml" title="Sitemap" href="https://www.pricetargets.com/Sitemap.ashx" /><link rel="sitemap" href="https://www.pricetargets.com/Sitemap.ashx" />

<!--[if lt IE 9]>
        <link rel="stylesheet" href="/Style/olderbrowsers/css/bootstrap.min.css" media="all" />
        <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
        <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
    <![endif]-->
<link rel="publisher" href="https://plus.google.com/114849885938379193299/" />
<!--[if IE]>
    
    <![endif]-->
<!--[if lt IE 9]>
      <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js"></script>
    <![endif]-->
<!--[if (gte IE 9) | (!IE)]><!-->
<script defer src="https://ajax.googleapis.com/ajax/libs/jquery/3.6.0/jquery.min.js"></script>
<!--<![endif]-->
<!-- -->
<link rel="manifest" href="/manifest.json" />
<script src="https://accounts.google.com/gsi/client" async defer></script>
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
<script>




       function registerUserChange(action) {
           OneSignal.getUserId(function (userId) {
               OneSignalIdString = userId;
               var Domain = 'analystratings.net';
               var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
               var xhr = new XMLHttpRequest();
               xhr.open('GET', url);
               xhr.onload = function () {
                   if (xhr.status !== 200) {
                       console.log('GET failed.  Returned status of ' + xhr.status);
                   }
                   else {
                       console.log('GET succeeded (' + url + ').  Returned status of ' + xhr.status);
                   }
               };
               xhr.send();
           });
       }

    var OneSignal = OneSignal || [];
       OneSignal.push(
           function () {
               OneSignal.init({
                   appId: "3c4d8727-d855-4e1c-ad92-4049d77fdb9d",
                   safari_web_id: 'web.onesignal.auto.64063cbd-bb2e-4678-8d54-7a11e3cbaa94',
                   autoRegister: false,
                   autoResubscribe: true,
                   notifyButton: {
                       enable: false
                   },
                   welcomeNotification: {
                       "title": "Join Wall Street's Brightest Minds.",
                       "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
                       "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
                   },
               });
               OneSignal.once('subscriptionChange', function (isSubscribed) {
                   if (isSubscribed) {
                       registerUserChange("subscribe");
                   }
                   else {
                       registerUserChange("unsubscribe");
                   }
               });
               if ((navigator.userAgent.toLowerCase().indexOf('firefox') > -1) || ((navigator.userAgent.toLowerCase().indexOf('safari') > -1) && (!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))) {
                   OneSignal.showSlidedownPrompt();
               } else {
                   OneSignal.showNativePrompt();
               }
           });

        

   </script>
<script data-ad-client="ca-pub-9373162611283935" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<meta name="description" content="KLA Corporation (NASDAQ: KLAC) is fundamental to the microchip industry and seeing a robust business because of the high demand. Not only are manufacturers ramping production but they are expanding and investing in next-generation technologies that promise to bring the full power of 5G to our fingertips." /><meta name="keywords" content="kls corporation stock, earnings, price target " /></head>
<body>
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
<div class="bg-eggplant">
<div class="header-1">
<div class="container">
<div class="row d-lg-flex pt-1">
<div class="c w-25">
<a href="https://www.pricetargets.com/" style="display:inline-block;max-width:calc(100vw - 120px)" id="header-logo-link">
<img width="260" height="50" src="/images/analyst-price-targets-logo.svg?v=2" alt="PriceTargets.com logo" />
</a>
<div style="float:right;" class="header-menu-trigger hamburger hamburger--collapse js-hamburger">
<div class="hamburger-box">
<div class="hamburger-inner"></div>
</div>
</div>
</div>
<nav class="c w-75 header-menu">
<ul>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/brokerages/">Ratings Issuers</a>
<ul>
<li><a href="/brokerages/bank-of-america-stock-recommendations/">Bank of America</a></li>
<li><a href="/brokerages/citigroup-stock-recommendations/">Citibank</a></li>
<li><a href="/brokerages/goldman-sachs-group-stock-recommendations/">Goldman Sachs</a></li>
<li><a href="/brokerages/morgan-stanley-stock-recommendations/">Morgan Stanley</a></li>
<li><a href="/brokerages/wells-fargo-co-stock-recommendations/">Wells Fargo</a></li>
<li><a href="/brokerages/">View All</a></li>
</ul>
</li>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/sectors/">Stocks By Sector</a>
<ul>
<li><a href="/basic-materials-stocks/">Basic Materials</a></li>
<li><a href="/consumer-stocks/">Consumer</a></li>
<li><a href="/energy-stocks/">Energy</a></li>
<li><a href="/finance-stocks/">Finance</a></li>
<li><a href="/healthcare-stocks/">Healthcare</a></li>
<li><a href="/industrials-stocks/">Industrials</a></li>
<li><a href="/real-estate-stocks/">Real Estate</a></li>
<li><a href="/retail-stocks/">Retail</a></li>
<li><a href="/technology-stocks/">Technology</a></li>
<li><a href="/transportation-stocks/">Transportation</a></li>
</ul>
</li>
<li class="has-submenu"><a class="level-1 bg-eggplant" href="/exchanges/">Stocks By Exchange</a>
<ul>
<li><a href="/NYSE/">New York Stock Exchange (NYSE)</a></li>
<li><a href="/NASDAQ/">NASDAQ</a></li>
<li><a href="/OTCMKTS/">Over The Counter (OTCMKTS)</a></li>
<li><a href="/LON/">London Stock Exchange (LSE)</a></li>
<li><a href="/TSE/">Toronto Stock Exchange (TSE)</a></li>
</ul>
</li>
<li><a class="level-1 bg-eggplant" href="/news/">News</a></li>
<li class="has-submenu">
<a class="level-1 bg-eggplant" href="/about/">About</a>
<ul>
<li><a href="/about/">About</a></li>
<li><a href="/authors/">Authors</a></li>
<li><a href="/contact/">Contact</a></li>
</ul>
</li>
<li>
<a class="level-1 bg-eggplant" href="javascript:openModal('companySearch');">Search</a>
</li>
<li>
<a href="#" class="button-header bg-eggplant" onclick="openModal('overlaySquareWhiteBlackMenuButton', 1, 'ARNet-popup');">Sign Up</a>
</li>
</ul>
</nav>
</div>
</div>
</div>
<div id='g_id_onload' data-client_id='178542853386-plp54kefhk8f9nq4770tavoqc0u5268b.apps.googleusercontent.com' data-login_uri='https://www.pricetargets.com/users/OneTapVerifyRedirect.aspx' data-auto_select='false' data-cancel_on_tap_outside='true' data-state_cookie_domain='marketbeat.com' data-skip_prompt_cookie='arnonetap'></div>
<div class="container">
<div id="flexPlace">
</div>
</div>
</div>
</header>
<main id="main">
<form method="post" action="./" id="form1">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="15ADE6CF" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/wEdAAM5zAGfgAy1zTtV4oPYXLVCRNsEg3Wa+DxW2r/ozlHNsnQo658hAh0LotAhxSAvsX84gZdaQ0Zj02UHsVen94TQRYKFMytzHmaLY6qEdS8dHw==" />
<div class="container py-1">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5992787070" data-ad-format="auto" data-full-width-responsive="true"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<hr class="mb-2" />
<article>
<h1>KLA Corporation Is On Watch For A Major Breakout</h1>
<div class="byline-size pb-1">Thursday, October 28, 2021 by Thomas Hughes</div>
<div class="row d-lg-flex">
<div class="c" style="flex: 5 0 337px; -ms-flex: 5 0 337px;">
<div class="body-copy">
<img class="alignleft" src="https://www.marketbeat.com/logos/articles/small_Depositphotos_69304659_S.jpg" alt="KLA Corporation Is On Watch For A Major Breakout" width="660" height="440" />
<h2>KLA Corporation Is Fundamental To Semiconductors&nbsp;</h2>
<p><strong>KLA Corporation <a href="https://www.pricetargets.com/NASDAQ/KLAC/">(NASDAQ: KLAC)</a></strong> is fundamental to the microchip industry and seeing a robust business because of the high demand. Not only are manufacturers ramping production but they are expanding and investing in next-generation technologies that promise to bring the full power of 5G to our fingertips. In the case of KLA Corporation, demand is high for products and services and we don&rsquo;t see an end to these trends anytime soon. It&rsquo;s estimated the global <a href="https://www.pricetargets.com/news/nio-pops-on-deliveries-new-analyst-perspective/">chip shortage</a> will linger until the end of next year at least and demand will remain robust for long afterward.&nbsp;</p>
<h2>KLA Corporation Beats And Raises, Shares Soar&nbsp;</h2>
<p>KLA Corporation squeaked out a mild 20 basis point beat relative to the consensus for revenue but that is where the weakness ends. The company&rsquo;s $2.08 billion in net revenue is up 35.11% over last year and last year revenue was up nearly 10%. Strength was seen in both the<a href="https://www.pricetargets.com/news/intel-poised-to-make-giga-investment-in-fighting-chip-shortage/"> products and services</a> categories with products gaining 42% over last year and services a smaller 15%.&nbsp;</p>
<p>Moving on to the earnings, the company experienced a robust 1900 basis point expansion in GAAP margin that helped deliver incredibly strong results on the bottom line. The adjusted margin contracted, however, but less than expected, and also left bottom-line results in good territory. On a GAAP basis, the company brought in $6.96 in EPS to beat the consensus by $2.64 while the adjusted $4.64 beat by a smaller $012. Regardless, the company reports record cash flow and free cash flow, as well as a willingness to funnel the income to its investors.&nbsp;</p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5992787070" data-ad-format="auto" data-full-width-responsive="true"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><hr><br>
<p>Turning to the guidance, the company set its revenue expectations for the 2nd quarter above the consensus estimate. The company is looking for revenue of $2.25 billion at the low end of the range compared to the Marketbeat.com consensus of $2.23 billion. In our view, investors should expect revenue to come in closer to the high end of $2.425 billion if not higher.&nbsp;</p>
<h2>KLA Corporation Is Returning Cash To Shareholders&nbsp;</h2>
<p>KLA Corporation has been generating strong cash flow for some time now and putting the money to good use. The company bought back roughly $400 million in shares during the quarter as well as paying out $163 million in dividends. At this pace, the $562.5 million in capital returns is only 70% of the free cash flow so we are expecting both buybacks and dividends to continue, and for both to be increased along with earnings growth. The dividend yield is a bit on the low side at 1.15% but roughly in line with the broad market average. The appeal here is the safety and the outlook for growth. Not only is FCF more than ample to sustain the dividend but the balance sheet is a fortress.&nbsp;</p>
<h2>The Analysts Drive KLA Corporation Higher&nbsp;</h2>
<p>The analysts are pretty bullish on KLA Corporation already but have begun to push the price target higher. At least 6 sell-side analysts have come out since the report and all include a price target increase and includes the new high price target of $490. The consensus among the 6 fresh targets is just over $410 compared to the Pricetargets.com <a href="https://www.pricetargets.com/NASDAQ/KLAC/#upgrades-and-downgrades">consensus of $385.</a> The $385 consensus assumes about 5% of upside for the stock while the high price target implies a more robust 36% advance for share prices. Price action is currently fighting with resistance at the all-time high, if that level can be surpassed we see the stock moving easily up to the $410 range if not higher.&nbsp;<br /><br /><img style="display: block; margin-left: auto; margin-right: auto;" src="https://www.marketbeat.com/logos/articles/small_chart-KLAC-10282021_ver001.png" alt="KLA Corporation Is On Watch For A Major Breakout" width="1200" height="630" /></p><h2 class='h3'>Companies in This Article:</h2><table class='tscrollable tsortable' style='line-height:1.2em'><thead><tr><th data-sort='string'>Company</th><th data-sort='float'>Current Price</th><th data-sort='float'>Price Change</th><th data-sort='float'>Dividend Yield</th><th data-sort='float'>P/E Ratio</th><th data-sort='float'>Consensus Rating</th><th data-sort='float'>Consensus Price Target</th></tr></thead><tbody><tr><td>KLA (<a href='/NASDAQ/KLAC/'>KLAC</a>)</td><td data-sort-value='357.07'>$357.07</td><td class='c-green' data-sort-value='0.0484481897994539'>+4.8%</td><td data-sort-value='0.011762399529504'>1.18%</td><td data-sort-value='26.67'>26.67</td><td data-sort-value='2.61111111111111'>Buy</td><td data-sort-value='375.294117647059'>$375.29</td></tr></tbody></table>
</div>
<div>
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatArticlePage.aspx" title="More on MarketBeat"></iframe>
</div>
</div>
<div class="c" style="flex: 0 0 337px; -ms-flex: 0 0 337px;">
<div class="mb-2 bg-eggplant p-1">
<h2 class="h2 m-0">Get New Analyst Ratings Delivered To Your Inbox</h2>
<div class="py-1">Enter your email address below to receive a concise daily summary of analysts' upgrades, downgrades and new coverage with <a href="https://www.marketbeat.com/?utm_source=PriceTargetCom&utm_campaign=PriceTargetCom&utm_medium=PriceTargetCom" class="no-a">MarketBeat</a>'s FREE daily email newsletter.</div>
<div class="pb-1">
<input name="ctl00$cphPrimaryContent$InPostRegistrationEmail" type="text" id="cphPrimaryContent_InPostRegistrationEmail" name="RegisterEmail" placeholder="your@email.here" aria-label="Enter Your Email" class="transparent-input" style="width:100%;" />
<div id="ShowSuggestionInPost" class="c-white"></div>
</div>
<div class="pb-1">
<input type="submit" name="ctl00$cphPrimaryContent$btnSubmit" value="Sign Up Now (Free)" onclick="return CheckEmail(&#39;cphPrimaryContent_InPostRegistrationEmail&#39;, &#39;ShowSuggestionInPost&#39;);" id="cphPrimaryContent_btnSubmit" class="button button-gold" style="width:100%;" />
</div>
</div>
<div>
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx?PlaceOnArticlePage=1" width="336" height="600" frameborder="no" title="More Articles"></iframe>
</div>
<h2 class='m-0 h3'>Most Read This Month</h2><ul class='styled-list m-0'><li><a href='/news/wall-street-is-raising-target-prices-for-these-3-stocks/'>Wall Street is Raising Target Prices for These 3 Stocks</a></li><li><a href='/news/three-reasons-the-correction-is-over-for-now/'>Three Reasons The Correction Is Over, For Now</a></li><li><a href='/news/kraft-heinz-confirms-reversal/'>Kraft-Heinz Confirms Reversal </a></li><li><a href='/news/early-cycle-alcoa-is-poised-for-big-gains/'>Early-cycle Alcoa Is Poised For Big Gains</a></li><li><a href='/news/dont-buy-sherwin-williams-yet/'>Don't Buy Sherwin-Williams, Yet</a></li></ul><h2 class='h3 mt-2'>Recent Articles</h2><ul class='styled-list m-0'><li><a href='/news/kla-corporation-is-on-watch-for-a-major-breakout/'>KLA Corporation Is On Watch For A Major Breakout</a></li><li><a href='/news/kraft-heinz-confirms-reversal/'>Kraft-Heinz Confirms Reversal </a></li><li><a href='/news/vf-corporation-struggles-with-supply-chain/'>V.F. Corporation Struggles With Supply Chain </a></li><li><a href='/news/analysts-are-lowering-price-targets-on-these-3-re-opening-stocks/'>Analysts are Lowering Price Targets on These 3 Re-opening Stocks</a></li><li><a href='/news/chipotle-mexican-grill-adds-spice-to-earnings-season/'>Chipotle Mexican Grill Adds Spice To Earnings Season</a></li></ul>
</div>
</div>
</article>
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/ViewCount.ashx?type=j&id=4925541&referrer=' + encodeURIComponent(document.referrer) + '" alt="" />');</script>
</div>
<div class="container">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5992787070" data-ad-format="auto" data-full-width-responsive="true"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
<script type="application/ld+json"> { "@context": "http://schema.org", "@type": "NewsArticle", "mainEntityOfPage": { "@type": "WebPage", "@id": "https://www.pricetargets.com/news/kla-corporation-is-on-watch-for-a-major-breakout/" }, "headline": "KLA Corporation Is On Watch For A Major Breakout", "image": { "@type": "ImageObject", "url": "https://www.marketbeat.com/logos/articles/small_Depositphotos_69304659_S.jpg", "height": "400", "width": "400" }, "datePublished": "2021-10-28", "dateModified": "2021-10-28", "author": { "@type": "Person", "name": "Thomas Hughes", "url":"https://www.pricetargets.com/authors/thomas-hughes/" }, "publisher": { "@type": "Organization", "name": "PriceTargets.com", "logo": { "@type": "ImageObject", "url": "https://www.pricetargets.com/images/arn-h-logo-2c-light-bkg-rgb-300px@72ppi.jpg", "width": "300", "height": "53" } }, "description": "KLA Corporation (NASDAQ: KLAC) is fundamental to the microchip industry and seeing a robust business because of the high demand. Not only are manufacturers ramping production but they are expanding and investing in next-generation technologies that promise to bring the full power of 5G to our fingertips." } </script><link rel="canonical" href="https://www.pricetargets.com/news/kla-corporation-is-on-watch-for-a-major-breakout/" /><link rel="amphtml" href="https://www.pricetargets.com/news/kla-corporation-is-on-watch-for-a-major-breakout/amp/" /><meta name="twitter:card" content="summary" /><meta name="twitter:site" content="@MarketBeatCom" /><meta name="twitter:title" content="KLA Corporation Is On Watch For A Major Breakout" /><meta name="twitter:description" content="KLA Corporation (NASDAQ: KLAC) is fundamental to the microchip industry and seeing a robust business because of the high demand. Not only are manufacturers ramping production but they are expanding and investing in next-generation technologies that promise to bring the full power of 5G to our fingertips." /><meta name="twitter:creator" content="@MarketBeatCom" /><meta name="twitter:image" content="https://www.marketbeat.com/logos/articles/small_Depositphotos_69304659_S.jpg" /><meta property="og:title" content="KLA Corporation Is On Watch For A Major Breakout" /><meta property="og:type" content="article" /><meta property="og:url" content="https://www.pricetargets.com/news/kla-corporation-is-on-watch-for-a-major-breakout/" /><meta property="og:image" content="https://www.marketbeat.com/logos/articles/small_Depositphotos_69304659_S.jpg" /><meta property="og:description" content="KLA Corporation (NASDAQ: KLAC) is fundamental to the microchip industry and seeing a robust business because of the high demand. Not only are manufacturers ramping production but they are expanding and investing in next-generation technologies that promise to bring the full power of 5G to our fingertips." /><meta property="og:site_name" content="PriceTargets.com" /><meta property="og:locale" content="en_US" />
</form>
</main>
<footer class="bg-eggplant pt-1" style="padding-bottom: 4rem;">
<div class="container py-1">
<p>© American Consumer News, LLC dba PriceTargets.com ® 2010-2021. All rights reserved. 326 E 8th St #105, Sioux Falls, SD 57103. PriceTargets.com provides comprehensive coverage of stock ratings, including equities research analysts’ upgrades, downgrades, new coverage and price target
changes. PriceTargets.com keeps track of all major brokerages’ stock ratings and recommendations, including Goldman Sachs, JPMorgan Chase, Wells Fargo, Bank of America/Merrill Lynch, Citigroup, Morgan Stanley and many more. PriceTargets.com does not provide financial advice and does not issue recommendations or offers to buy stock or
sell any security.</p>
<a href="/accessibility/" style="color:#fff;font-weight:300;">Our Accessibility Statement</a> | <a href="https://www.marketbeat.com/do-not-sell-my-information/" style="color:#fff;font-weight:300;">Do Not Sell My Information</a>
<br />
<br />
<hr class="my-1" />
<p>
© 2021 Market data provided is at least 10-minutes delayed and hosted by <a class="c-white" style="font-weight:300;" href='https://www.barchartmarketdata.com/' rel="noopener nofollow">Barchart Solutions</a>. Information is provided 'as-is' and solely for informational purposes, not for trading purposes or advice, and is delayed. To see all exchange delays and terms of use please see <a class="c-white" style="font-weight:300;" href="https://www.barchartmarketdata.com/terms" rel="noopener nofollow">disclaimer</a>. Fundamental company data provided by Zacks Investment Research. As a bonus to opt-ing into our email newsletters, you will also get a free subscription to the Liberty Through Wealth e-newsletter. You can opt out at any time.
</p>
</div>
</footer>
<script type="text/javascript" src="/scripts/ARNMasterScripts.js?v=20210816"></script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-0EPCLQ469L"></script>
<script>
        window.dataLayer = window.dataLayer || [];
        function gtag() { dataLayer.push(arguments); }
        gtag('js', new Date());

        gtag('config', 'G-0EPCLQ469L');
    </script>
<script type="text/javascript">loadEntranceModal('ARNet-Popup'); </script>

<script type="text/javascript">
    var sc_project = 12386963;
    var sc_invisible = 1;
    var sc_security = "d815ef40";
    var sc_https = 1; 
    </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/12386963/0/d815ef40/1/" alt="Web Analytics Made Easy - StatCounter"></noscript>

</body>
</html>
